Changes between Version 23 and Version 24 of SystemPlatformsEN


Ignore:
Timestamp:
Mar 1, 2014, 12:21:56 PM (8 years ago)
Author:
Martin Kolman
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • SystemPlatformsEN

    v23 v24  
    77This section describes platforms currently supported by modRana. Other platforms have simply not been tested yet :)
    88
    9 Following software packages are needed for running modRana:
    10  * Python 2.5
     9Following software packages are needed for running modRana with the GTK GUI:
     10 * Python 2.5+
    1111 * PyGTK
    1212 * Cairo
     
    1414 * espaek (optional)
    1515
    16 
    17 == !NeoFreeRunner @ SHR ==
    18 
    19 The default SHR installation already has all the essential dependencies needed by modRana. To get spoken turn-by-turn directions, install '''espeak'''.
     16To run the Qt GUI you will need:
     17 * Python 3+
     18 * Qt 5.1+
     19 * PyOtherSide
    2020
    2121
     
    4545 * modRana uses native Maemo5 notifications and has a Maemo5 application-menu(a menu activated by clicking on the window title)
    4646
     47== Sailfish OS ==
     48
     49!ModRana runs fine on Sailfish OS and is already available from the [https://openrepos.net/content/martink/modrana-0 OpenRepos application repository].
     50
    4751== Harmattan @ Nokia N9 and N950 ==
    4852
     
    5357
    5458[http://repo.pub.meego.com/home:/MartinK:/modrana/MeeGo_1.2_Harmattan_Maemo.org_MeeGo_1.2_Harmattan_standard/armel/ modRana Harmattan package repository]
     59
     60== !NeoFreeRunner @ SHR ==
     61
     62The default SHR installation already has all the essential dependencies needed by modRana. To get spoken turn-by-turn directions, install '''espeak'''.
    5563
    5664== HP Touchpad ==